
1 | WordpressAcademy.biz                                                                                                 

 

 

http://www.makeuseof.com/
http://wordpressacademy.biz/


2 | WordpressAcademy.biz                                                                                                 

 

 

TABLE OF CONTENTS 

Introduction ............................................................................................................................ 4 

What you will learn from this eBook ........................................................................................... 4 

How to find out more .................................................................................................................. 4 

1. Building Your WordPress Installation 

What is WordPress .................................................................................................................. 6 

WordPress Hosting options ...................................................................................................... 6 

Understanding self-hosted WordPress sites vs. WordPress.com ................................................ 6 

Understanding domain and hosting ........................................................................................... 6 

Choosing a webhost and domain registrar ................................................................................. 7 

To assign a domain name to a hosting account ......................................................................... 8 

Installing WordPress on your hosting account ............................................................................ 9 

Creating email accounts with your domain name ...................................................................... 9 

2. Customizing Your Website or Blog 

WordPress basic concepts & layouts ...................................................................................... 11 

Theme Selection .................................................................................................................... 12 

Finding a good theme ............................................................................................................... 12 

Installing and activating your theme ........................................................................................ 13 

How to customize (style) a theme ............................................................................................. 13 

Special instructions for Atahualpa theme users ........................................................................ 14 

Understanding Posts, Pages and Links.................................................................................... 14 

Basic WordPress configuration .............................................................................................. 15 

Sidebars and Widgets ............................................................................................................ 16 

Additional help on Widgets and navigating the User Interface ................................................ 19 

Installing a recommended Plugin set ..................................................................................... 20 

Creating a banner for your website ........................................................................................ 21 

http://wordpressacademy.biz/�
http://www.makeuseof.com/�


3 | WordpressAcademy.biz                                                                                                 

 

3. Publishing Content with WordPress 

Using the WordPress built-in Visual Editor ............................................................................. 29 

Windows Live Writer and Blogo (on Mac OS X) ...................................................................... 29 

Conclusion ............................................................................................................................. 31 

About the author & Contact Details ....................................................................................... 31 

 

Don’t miss out on our other cool manuals! ................................................................................... 32 

 

 

  

http://wordpressacademy.biz/�
http://www.makeuseof.com/�


4 | WordpressAcademy.biz                                                                                                 

 

INTRODUCTION 

WHAT YOU WILL LEARN FROM THIS EBOOK 

MakeUseOf.com collabozrated with WordPress Academy to bring you this manual. The “WordPress 101 
Quick Start Guide:  Your first site in 2 hours” is an eBook and companion video training course designed 
to teach you how to get your first WordPress website up and running in two hours, without any prior 
knowledge.  It will save you dozens of hours in research and avoid having to go back and redo anything 
later, as your site grows and becomes more refined (which it will). 

This is the same curriculum that is taught in the first two sessions (4 hours) of the Full WordPress 101, 16 
hour webinar course on WordPress Academy. 

Topics covered in this eBook include 

 WordPress hosting options 
 Basic concepts: site elements and layout 
 Theme selection: your best choices  
 Configuring WordPress for a business website 
 Understanding Posts, Pages and Links  
 Using sidebars and widgets  
 Creating content: the WP built-in Visual editor  
 Installing plugins, and a recommended plugin set  
 Basic Atahualpa theme styling and configuration  
 Creating rich content with Windows Live Writer or Blogo  
 Making a website banner using free image-editing software 

HOW TO FIND OUT MORE 

If you are serious about developing and making money from your site, you may want to consider taking 
the Full WordPress 101 course on WordPress Academy 

In addition, we have some additional juicy content set aside specifically for MakeUseOf.com 

subscribers, including the eBooks: 

 Fast Traffic to your WordPress blog: how to perform a quick keyword analysis and search-engine 
optimization for your site and start immediately attracting search-engine traffic  

 Atahualpa theme styling guide: In-depth styling guide to this powerful free theme framework, 
including instructions on using the 20+ pages of theme options 

To access this content, go to http://wordpressacademy.biz/muo and become a member for free.  This will 
also give you access to our monthly free webinars on topics such as: 

 Advanced WordPress SEO 
 Creating a WordPress membership site 
 Becoming a professional blogger 
 And much more… 
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BUILDING YOUR WORDPRESS INSTALLATION 
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WHAT IS WORDPRESS 

WordPress is a Content Management System (CMS): it allows you to create and maintain a website 
through an administrative interface, including an automatically-generated navigation structure (page 
menu bar etc), without needing to know HTML or learn any other tool. It is simple enough for a beginner 
to learn in a few hours, without sacrificing any power or flexibility.  You can do virtually anything with it. 

WordPress is an Open Source Software: created by thousands of programmers all over the world and put 
into the public domain, so you do not have to pay to use it 

WordPress is a web-based application, written in PHP and MySQL, designed to run on Linux servers: PHP 
is a programming language for web applications, MySQL is a relational database (such as Microsoft 
Access), and Linux is an operating system for web servers – all of these are also open-source. 

WordPress is, by far, the most popular CMS: over 200 million sites worldwide as of late 2009. 

WordPress is an excellent platform for creating a small business or professional website.  Even though it 
was originally designed as a blogging platform, it works very well for creating ordinary (static) websites as 
well.  It’s also great for membership sites (sites where you sell you content for a fee). 

WordPress comes with thousands of free themes (templates or styles) and plugins (add-on 
applications).  Changing your theme or adding a plugin is extremely easy.   

Many WordPress users and developers consider it the “shangri-la” of website development – the 
elusive goal of simple and powerful website development for non-technical people is now here.  Previous 
platforms were either too difficult to learn  (Joomla and Drupal CMS’s), proprietary and too limited 
(Godaddy’s “Website tonight”), or expensive.   

WORDPRESS HOSTING OPTIONS 

UNDERSTANDING SELF-HOSTED WORDPRESS SITES VS. WORDPRESS.COM  

You can create a free WordPress blog at WordPress.com, and then assign it to your own domain name for 
about $20 per year. The content will be hosted on the WordPress servers, and as such you needn’t worry 
about hosting. 

This is not recommended, because WordPress.com has a limited number of available themes and plugins 
– in particular, commercial themes are not supported, nor the free Atahualpa theme. You will further be 
limited in terms of your ability to really customize the site. Wordpress.com does not give you access to 
your PHP code. 

It’s much better to host your WordPress site yourself using the so-called “self-hosted WordPress”.  

UNDERSTANDING DOMAIN AND HOSTING 

To host a website, you need a Domain Name Registrar company (e.g. GoDaddy) and a Hosting Company 
(e.g. BlueHost). Occasionally, the same company handles both, but they’re typically separated. Hosting 
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companies are sometimes known to include one free domain name in the hosting plan but then charge a 
premium fee for additional domains. 

CHOOSING A WEBHOST AND DOMAIN REGISTRAR 

Your hosting company holds (or “stores”) the files on your website to anyone who asks for them 
anywhere in the world. Hosting companies run banks of web servers, which are essentially big computers 
that are always turned on, connected to the internet, and monitored 24 hours in case of failure. 

The leading hosting companies are listed below.  They are all more or less equivalent in terms of pricing, 
service level and reliability.  Prices range from $6 to $10/mth, depending on the contract duration and 
options -- particularly whether multiple domains can be hosted under one account or not -- and whether 
the domain name is included or not.   

BlueHost and Hostgator are cPanel style hosts, which are easier to manage and navigate than GoDaddy’s 
interface.  BlueHost and GoDaddy are probably the best.  In comparing the two, consider that you need to 
budget about $10/year on top of GoDaddy hosting to pay for your primary domain name, which is already 
included in BlueHost.  It evens out pretty well in the end. 

• GoDaddy.  World’s leading domain name registrar and hosting provider.  Make sure you buy the 
Deluxe or Unlimited plan, since the Economy plan only allows you to host one site and as of now it is 
not possible to upgrade from an Economy to Deluxe plan. GoDaddy’s user interface can be a bit 
difficult to understand and navigate. 

• BlueHost. Perhaps the best all-around value.  It does require a year prepay, but already includes one 
domain name, and uses the easier cPanel interface. 

• Hostgator.  Also a great company.  Unique among companies listed here, it offers so-called “reseller 
hosting” plans, where you can set your clients up with their own hosting control panels and charge 
them for it. This is especially interesting for website designers, provided you are ok taking 3am phone 
calls; “my email is down, please help”.  

• Dreamhost.  Another great hosting alternative. 
 

Additional Notes: 

• Remember that even if your hosting company allows you to host unlimited domains, you still need to 
pay the yearly fee for each domain you are hosting, which is currently about $10/yr. 

• It’s preferable to install WordPress on a Linux hosting server. This is usually not an issue since all low-
cost hosting accounts are Linux-based.  If you already have Windows hosting, WordPress will run fine 
on it, though. 

• Never purchase hosting based on price alone

• If you are just learning, and/or programming websites in PHP, you could use 

.  There are other elements in the equation, like server 
speed and reliability. If you have email accounts attached to your domain name 
(you@yourdomain.com) the email is managed by your web server (hosting company), and if the 
server goes down so does your email (sometimes for days) 

local server hosting  
instead – it only takes a few minutes to install on your computer (and is a fun exercise to do anyway).   
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• If you can, build your website on the host that is the website’s ultimate destination, since moving 
websites from one host to another can be tricky. Just changing domain names on a live site is usually 
not a problem. For more information on moving a WordPress site from one host to another, see this 
article. 

• If you are building a new version of an existing website, intending to replace the original, build it in a 
subdirectory i.e. http://mycompany.com/new

 

, and then move it to the root directory when you are 
done.  

TO ASSIGN A DOMAIN NAME TO A HOSTING ACCOUNT 

Pairing webhost and registrar is also called “hosting your domain”. 

1. If you don’t yet have a hosting account, sign up for one (see below).   

2. If you are hosting the primary domain of your site, your domain is automatically hosted when 
you open your hosting account, so skip directly to step 6. 

3. If you want to create an additional website in your hosting plan (assuming that your hosting plan 
allows it), do the following:  
- If you have a cPanel hosting account (such as BlueHost or Hostgator), open your hosting 
control panel and choose the “add-on domain” function, which assigns the domain name to a 
sub-directory of your site 
- If you are using GoDaddy, open the domain in your control panel and then select the “Hosting” 
option for that domain, and create an additional hosted domain.  

4. Go to your domain name registrar control panel, and from there set the Name Servers of your 
domain as instructed by your hosting company (i.e. if you are using BlueHost you would set your 
Primary and Secondary name servers to NS1.BLUEHOST.COM and NS2.BLUEHOST.COM 
respectively).  GoDaddy will do this for you automatically if you follow the previous step. 

5. Your website will typically be visible on the web (“resolved to your domain name”) within a few 
hours – overnight maximum (this delay is called “domain propagation time”).  If you have not put 
any files on your site yet you will see either an “empty directory listing” or else the default 
landing page for your hosting company.  

6. Use the automated WordPress installer on your hosting control panel to install a fresh 
WordPress site to your domain. If all goes well, you will now see the default WordPress 
installation at http://yourdomain.com

Tip: it is generally easier to assign your name servers when you first purchase your domain name rather 
than after you have bought it. This also eliminates the domain propagation delay, allowing your site to 
come online immediately.  If registering your domains at GoDaddy, look for a little box that says “Set 
name servers” during the purchase cycle. 
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INSTALLING WORDPRESS ON YOUR HOSTING ACCOUNT 

Almost all hosts have a 2-click WordPress installer program.  Google “Installing WordPress on [your 
hosting company]” for instructions, or else review the Installation tutorials on WordPress.TV. 

A WordPress installation consists both of PHP files and a MySQL database.  Backing it up fully will require 
both backing up the PHP files and the database.  See below for how to backup your site’s database (use 
plugin WP-DB-Backup).  Most of your site’s configuration is kept in your database, so failure to backup 
your PHP files is generally not a big issue in the case of failure (but do it anyway for precaution).  You can 
backup your entire site through your hosting control panel. 

CREATING EMAIL ACCOUNTS WITH YOUR DOMAIN NAME 

This is done within the hosting control panel.  There are two ways you can create an email address 
attached to your domain name (e.g. myname@mycompany.com

• A Forwarding email address just forwards to another email (i.e. your Gmail) 

).   

• A POP3 email address stores the email on the server and downloads to your computer through your 
email client program (i.e. Microsoft Outlook etc.) 

Both have advantages and disadvantages over the other. Generally, it is faster to read and process email 
in an email program (email client) rather than a web-based client (e.g. Gmail).  The trade-off is that web-
based email allows you access to your email from anywhere, and may have better spam filtering. 

Note: all major web hosting companies provide Webmail interfaces to their POP3 email accounts, so you 
can still read your mail via POP3 at home and access it from the road.  However, once your POP3 email is 
downloaded to your computer (once it is read), it is no longer accessible through webmail. 
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CUSTOMIZING YOUR WEBSITE OR BLOG 
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WORDPRESS BASIC CONCEPTS & LAYOUTS 

This is what WordPress looks like after installation of our favorite theme, Atahualpa.  You need to 
understand this to design your site’s layout and navigation.   

Every theme looks different but they share all or some of the elements below. 

 

Notes: 

• When you first install WordPress, the installer automatically creates a Page called “About”, a Post 
called “Hello World”, and a set of Links in the category “Blogroll”.  The first thing you will typically do 
is to delete these and create your own content. See below for the difference between Pages, Posts 
and Links. 

• Until you put content (widgets) into your sidebars, WordPress will populate them with default 
widgets.  In the example above, the left sidebar is automatically filled with a “Categories” and an 
“Archives” widget, and the right sidebar has a “Recent Posts” and a “Links” widget.  To replace these 
with your own content, see below.   

• The ;page navigation is usually located on a horizontal bar (with or without drop-downs to sub-
pages), above or below the banner image. You can put it in a “pages” widget on either the left or right 
sidebar (see below for what a “pages widget” is)  

• The page navigation bar normally contains only your static pages (WordPress “Pages”) and is auto-
generated, but you can use pretty much anything you want, like blog categories, or external links. 

http://wordpressacademy.biz/�
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• In the Atahualpa theme, the Title and Tagline can overlay the banner image.  Or, you may remove the 
Title and Tagline altogether and place them in your banner as image text (see below “Making a 
banner using Paint.net”).  

• You must think on your sidebar configuration.  Depending on your theme, you can have up to 4 
sidebars: left, left inner, right inner, right.  Some themes and theme frameworks will allow you to 
selectively set visibility of sidebars according to page type (Page or Post) or by Page ID (i.e. turn off 
side-bars for the home page). 

THEME SELECTION 

FINDING A GOOD THEME 

This is an important decision for several reasons: 

• Your site’s appearance is determined largely by your theme.  A good theme will make the 
difference between a professional-looking site and one that isn’t. 

• You should choose your theme fairly soon after you begin your site, since it has an impact on 
how you create your content (i.e. two or three-column layouts, screen width, etc).  In WordPress, 
content is mostly separate from presentation, so you can always change your theme later. 
However, if you do this, you will lose most of the work that you have put into customizing your 
theme. 

• Themes are customizable to differing degrees. Modifying the PHP theme files directly can 
customize all themes, but this can be technical and time-consuming.  You are better off choosing 
a theme that already has the functionality and look that you want.  You are also typically better 
off choosing a Theme framework over a regular theme. A theme framework allows you to 
customize options such as the presence or absence of sidebars directly through the theme 
options page. 

Theme selection is more of an art than a science, but here is how I get my clients started:  

1. Start with WordPress’ most popular (free) themes

2. If you are looking for a theme for a specific business type, try searching the 

 – you may find a bull’s eye theme there, and if 
not, you might get some ideas.  Remember that there are disadvantages to using a regular theme 
vs. a theme framework, even if that theme is great from a visual point of view (see below). 

WordPress.org free 
themes directory site or else Googling it directly. 

3. Consider Artisteer ($50).  This is Windows software that allows you to design the layout locally 
and provides a lot of options.  When you are done, export the theme files and upload to your site 
with FTP.  It creates visually rich sites, although a bit on the simple side.  Also works for Joomla 
and Drupal content management systems. 

4. However, recommended Theme frameworks are:  
o Atahualpa (free, install from your WP Dashboard, see below) 
o Thesis 
o iThemes (Builder or Flexx especially) 
o Any Studio Press theme 

The reason a theme framework is recommended, is that almost can be customized in the theme 
options within your dashboard, rather than modifying the theme files in PHP.  Remember: you 
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can do almost anything you want with WordPress – however, the workload depends on whether 
your theme already supports it, and/or whether you can find a suitable plugin. 

Quality of support is also a serious concern.  In many cases paid themes provide better 
support.  The exception to this is Atahualpa, which again is well-supported in user forums.  

5. Honorable mention (paid): WooThemes and ThemeForest themes (Themeforest is a large 
directory of themes priced from $3 and up). 

6. Honorable mention (free): WhiteHouse, Hybrid, Thematic, Revolution and Lysa.  These all install 
directly from your WP dashboard and have a clean uncluttered look 

7. If you are going with Atahualpa, look for inspiration to the Atahualpa theme showcase 
and Atahualpa showing off thread on the Bytes For All support forum. 

8. Decide if you are going to need drop-down menus, since not all themes support them. If you 
have less than 10 pages on your site, do not use drop-down menus. 

INSTALLING AND ACTIVATING YOUR THEME 

If you are using a free theme, install and activate it directly through your dashboard: Appearance > Add 
New Theme, search for it by name, then install and activate it. 

If you purchase a commercial theme, you will need to upload it to your web site and activate it.   

The easiest way to do this is via the Theme > Add New Theme command (in your WordPress dashboard). 
Select the "Upload" tab, find and upload the theme zip file provided by your theme vendor.   

The second way is to unzip the theme files and upload them via FTP.  You will need FTP client software for 
this (e.g. FileZilla), and you will need to know your hosting account username and password.  See this 
article for additional instructions. 

HOW TO CUSTOMIZE (STYLE) A THEME 

The first thing you will usually do is add a company banner and logo.  See below for making a banner using 
the free image editing software Paint.net (available only on Windows).  You can also use the free Gimp 
image editing software (available on all platforms) or purchase Photoshop Elements for $25-$50.   

You will usually need to upload your banner image to your website using FTP, and place it inside the 
correct directory of your server. 

Check out your customizable theme options (in WordPress Admin > Appearance > Theme Options).  If you 
are using a theme framework, you will be able to set the width of your site, the presence of sidebars, and 
many other options. 

The best themes and theme frameworks also give you control of the styling of every element of your site, 
such as background color, font, margins, etc.  You need to know a little CSS to do this, but this is quite 
simple and if in doubt you can Google “CSS background color” for the precise syntax, or to go 
to W3Schools CSS tutorial.   
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If your theme options page doesn’t expose all the CSS styles, you can still modify the CSS file directly. This 
is a bit technical, and not recommended for regular users.  You can access your site’s CSS file in 
Appearance > Edit and then edit the CSS file from there. 

If you are modifying your site’s CSS, you might want to take a look at Firebug, a Firefox add-on that lets 
you examine each element of another site your like, view the underlying CSS code, and modify the CSS 
code on the fly and see the results.  You can use it, essentially, to copy the styling of any site on the 
internet (and it’s legal!).   

CSS styling commands need the hex color code, looking like #AA0944 – this is hexadecimal notation, two 
hex digits each for the color values: Red, Green, Blue (00 to FF). You can find / detect color settings on 
another website using the Firefox Colorzilla add-on. 

SPECIAL INSTRUCTIONS FOR ATAHUALPA THEME USERS 

We have made a 30-minute video on YouTube to teach you specifically how to style the Atahualpa 
theme.  Check it out.  

UNDERSTANDING POSTS, PAGES AND LINKS 

You need to understand the basic WordPress data elements. 

• Posts are time-sensitive articles, and are normally listed on your “Blog” page in reverse chronological 
order.  You may choose not to have a “Blog” page at all (e.g. your site could have only static pages or 
“Pages”), OR you may choose to configure your WordPress site as a blog and to have your home page 
display your blog posts (this is the default configuration).  Posts allow comments, although you can 
close or disable comments on individual posts. 
 
Posts have categories.  You set up your post categories in the Posts > Categories menu.  If you create 
a post but don’t assign a category, it automatically gets assigned to the “Uncategorized” category 
(which you can rename to something else).  Categories can show up on your sidebar with the “Post 
categories” widget. 

• Pages are so-called static pages – they display content that isn’t time-sensitive, such as your Home 
page, About Us, Services page, and so on.   

Pages do not

Pages do 

 normally allow comments, nor are they part of your RSS feed (content distribution).  

not

 

 have categories, but can be created in a hierarchical structure. Depending on your 
theme, this could allow you to create drop-down menus in your navigation bar. 
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“Resources”, “About us” are top-level pages (no parent).  “WordPress Themes” etc are child pages of 
the “Resources” page. 

• Links are just that – URL’s to other pages on your site, or to external web pages. 
Links have categories too, albeit different from the Post categories.  The beauty of link categories is 
that you can use it to automatically populate your sidebars with groups of links, just by placing a 
single widget in your sidebar – see below. 

Additional Notes: 

• Posts, Pages and Links are each created from their own menus in your dashboard. 

• There are “widgets” (see below) that allow you to automatically put your list of Pages, Recent Posts, 
Posts by Category, Posts Archive, Post Comments, and other content directly into your sidebar(s). 

BASIC WORDPRESS CONFIGURATION 

Many of WordPress’ default settings are good, but you will want to change the following.  Do this from 
your site dashboard, at http://yoursitename.com/wp-admin

• Settings > General: Your blog name and tagline (tagline may appear on your header) 

.   

• Settings > Writing: Check the box “Enable the WordPress, Movable Type, MetaWeblog and Blogger 
XML-RPC publishing protocols” in order for Windows Live Writer to work (see below)  

• Settings > Reading: This is where you decide if you are having a blog (posts on home page) or a static 
website (static home page). WordPress is configured as a blog by default. A company website will 
often have a static landing page, and a blog subsection of the site. Here’s how you configure it. 
 
Create two pages called “Home” (this is your home page), and “Blog” (this is a “place-holder” page – 
WordPress will fill it with your latest posts).  Then select Front Page displays > A static home page 
and put “Home” and “Blog” in the drop-down menu. 
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Now go back to your site, refresh, and select your “Blog” page in your top page navigation bar – you 
will see it filled it with your most recent posts. 

• Settings > Privacy.  Select “I would like my blog to be visible to everyone” (this modifies your 
robots.txt file – informs search-engines of your intentions). 

• Settings > Permalinks.  Makes your URL’s (links to your articles) friendlier by putting the post or page 
title in the URL.  Generally, you will select Month and Name. 
 

 

SIDEBARS AND WIDGETS 

Widgets offer new and exciting ways to remix and display your site’s content, often in one of the sidebars. 
For more information, you may want to begin with the Widget Overview video on WordPress.TV 

To configure the widgets for your site, 

1. Go to Appearance > Widgets in your WP Dashboard. 

2. On the left you will see all your available widgets.  Some of these may be standard widgets that 
are installed by default in WordPress; others may be created by plugins (see below).  For 
example the “My Link Order” widget is automatically created when you install that plugin. 

3. To insert a widget into a sidebar, first expand the sidebar by pulling it down (arrow on the right).  
Then “Drag and Drop” your widgets on your sidebar.   
In the example below, we are putting a “Pages” widget into our left sidebar, right below the 
“Category Posts” widget. This will automatically populate your sidebar with the list of static 
pages on your site. 
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To illustrate this idea further, it’s best to use an example – on the next page is the WordPress Academy’s 
“How-To” page, a blog type page. 

Read this diagram carefully, and the next diagram as well, as it explains how to setup your sidebars 
however you want.  
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Here is what the right side of Appearance > Widgets looks like in order to generate this layout:   

 

Note that this layout (as most WordPress layouts) makes extensive use of the Text widget. This widget 
allows you to put arbitrary HTML text and images onto your sidebars (or even, in the case of the 
Advanced Text Widget, PHP code!) 

ADDITIONAL HELP ON WIDGETS AND NAVIGATING THE USER INTERFACE 

For additional tutorials see the WordPress.TV How-To section. If there is anything that you find 
particularly helpful there, just drop me an email and I will update this document with the link.   
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INSTALLING A RECOMMENDED PLUGIN SET 

A WordPress “Plugin” is a piece of software that is designed to perform a specific function and integrates 
seamlessly with your blog.  Most plugins are free and can be installed directly through your dashboard.   

Until you specifically “activate” them, plugins do not work on your site (they appear in your plugins menu 
as inactive, and have no effect).  So, if a plugin starts giving you problems, just deactivate it.  An inactive 
plugin can also be deleted, which physically removes the plugin files from your site. 

The following is the recommended minimum plugin set for all WordPress self-hosted sites.  Install each of 
them from Plugins > Add New. Enter the name in the search box, followed by Install and Activate: 

• PageMash allows you to order pages in your top navigation bar and sidebar by drag-and-drop, and 
can also hide pages from showing in your navigation (by default, all pages will show in your navbar 
and Pages widget, which is not normally what you want). 

• My Link Order lets you order links and link categories by drag-and-drop. 

• Subscribe to Comments allows users who comment on your articles to subscribe to follow-up 
comments, so they get notified when someone replies to them. 

• SI Captcha requires people who comment to fill-in a “captcha” code (4 digit computer-generated 
number) to make sure they are not spambots.  This is advised to protect you from spam comments.  
Note: you can also install Akismet (spam filter) but Akismet sometimes sends legitimate comments to 
your spam filter. 

• Redirection allows you to redirect one page to another.  Useful when you change the URL for an 
article, and for putting easy-to-remember affiliate links to your site 
(i.e. http://everymanmarketing.com/bluehost redirects to a Bluehost affiliate link – only a 
programmer can see the actual redirected link) 

• All-in-One SEO gives you fine-grained of all your meta-tags and site description. Some themes 
(particularly Thesis) have their own SEO and you won’t need All-In-One. 

• Google Analyticator is easy interface to free Google Analytics service.   

• XML Sitemap automatically generates an XML sitemap 

• EmailShroud provides email “cloaking” (hides email addresses from spambots).  This is not available 
in the plugins directory (one-click install), you will have to download it manually and upload the files 
from Plugins > Add New > Upload. 

• WP-DB-BACKUP allows you to backup your site.  

 

 

http://wordpressacademy.biz/�
http://www.makeuseof.com/�
http://everymanmarketing.com/bluehost�
http://www.somethinkodd.com/oddthinking/emailshroud-wordpress-plugin/�


21 | WordpressAcademy.biz                                                                                                 

 

Notes 

Some plugins automatically create new widgets.  For example the “My Link Order” plugin (above) creates 
a widget that lets you put ordered links and links categories to your sidebar. 

Don’t install plugins from untrustworthy sources, as plugins directly execute PHP code, which could even 
take your site down.  Anything you can see in your dashboard from Plugins >Add New comes from 
WordPress.org and is probably ok, albeit not guaranteed to work.   

Also note some very cool plugins (PHP Execution or Advanced Text Widget) that can directly execute your 
own (arbitrary) PHP code inside your pages and sidebars. If you know PHP, this will give you programmatic 
control of your sidebars content.   

CREATING A BANNER FOR YOUR WEBSITE 

Every website needs a decent banner. Here’s how to create one yourself in a flash. 

I love the free image editing software Paint.Net.  Unfortunately it only works on Windows.  If you are on 
Mac, try the free Gimp, which is also very good but harder to use.  Alternatively, you purchase Photoshop 
elements for $25-$50.  

Although the instructions below apply specifically to Paint.Net, the concepts are applicable to any image 
editing software. 

Here is the final result we are going to produce. 

 

1. Start Paint.Net.  Make sure the Tools window, the Layers window, and the Colors window are 
visible.  If not, enable them from the View menu. 
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2. Go to your favorite free stock photography site (Google “free stock photography” or 
check Stock.XCHNG), find the image you want for your logo, view it at the largest possible 
resolution, then Right-Click > Copy 

3. Edit > Paste in to New Image 

 

4. Click on Rectangle Select on the Tools Window (top left)  and use it to select the part of the 
image that you want.  Leave some space at the right to do the image fade-out (see below). 
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5. Do Image > Crop to Selection 

 

6. Decide on the banner height: 150 pixels is a good height. Do Image > Resize and enter a Height of 
150 and OK. 
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7. Choose your width depending on the width of your website (normally either 800 or 1000 
pixels).  Then go to Image > Canvas Size and put in a Width of 800.  Do not

 

 check Maintain 
Aspect Ratio 

Notice the right of the image has filled with empty or transparent pixels. If you are using a 
variable-width theme or template and using the image for the background image of the header 
area, you need to make it at least 1800 pixels, even though most browsers will only see the first 
1000 or 1200 pixels of width. 

8. Now let’s insert a background color / layer.  Go to Layers > Add New Layer.  The Image will 
remain unchanged but note the Layers window now shows a new layer, “Layer 2”. 
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9. First, for clarity sake, double click on “Layer 1” in the Layers Window and call it “Swan”.  Now 
double-click on “Layer 2” and call it “Background” 

 

To understand layers, uncheck the box next to “Swan” on the Layers Window.  This makes that layer not 
visible.  Now you only see the empty (transparent pixels) “Background” layer 

 

Within our image-editing program, every layer is a separate image. Images show up in a top-to-bottom 
layer order. The only reason we can see the layers ‘beneath’ is because there are transparent pixels on 
the upper layer(s).  
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The only reason the swan was showing at all is because the topmost “Background” layer is filled with 
empty (transparent) pixels. 

10. Let’s fill this background with a blue color closest to our original picture. First, make the Swan 
layer visible again and the Background layer invisible. Then select the Color Picker on the Tools 

Window and click on a darker area of the swan picture.  

Notice the Primary color on the Colors Window has changed to a dark blue. 

11. Go back to your background layer (click it in the Layers Window), select the Paint Bucket Tool 

 and click anywhere on the image. The entire image goes dark blue! 

 

The reason, of course, is that the “Background” layer is on top of the “Swan” layer. 

12. Move the Background layer down below the Swan layer. Click on “Background” in the layers 
window and then the down arrow: 

 

13. Next, go back to the Swan layer and select part of the overlap between the two layers. Go to 
Effects > Blurs > Gaussian blur to create a fade-over effect. 
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14. Now use the Text tool  to write your banner text. 

 

15. You can insert any other image by following the same procedure: add a new layer, crop and 
resize.  Remember new layers won’t be visible now unless they are on top. 

Hint - You can increase the screen resolution (visible size of your image) in the View menu, or 
else by putting your mouse over the image and Ctrl + move the mouse scroll bar. 

16. Now save the .pdn files, with all layers intact, in case you want to work more on it later. Then File 
> Save and save it as jpg to upload it to your website. 
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- 3 - 
 

PUBLISHING CONTENT WITH WORDPRESS 
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USING THE WORDPRESS BUILT-IN VISUAL EDITOR 

To create a new Page or Post, use Page > Add New to Post > Add New.  This will open up the WordPress 
Visual Editor. Make special note of the following: 

 

The editor is pretty straightforward and easy to use. For a more extensive introduction, check out the 
video tutorial How to format content using the WordPress WYSIWYG editor. 

Notes:  

• Add an image to your Media Library (and post it automatically in your article) with the “Upload / 

Insert Image” icon on the top left: .  

• Alternatively, use Windows Live Writer to create your posts, as described below. 

• As an alternative to the above, I recommend that you upgrade to the Tiny MCE Advanced editor. 

WINDOWS LIVE WRITER AND BLOGO (ON MAC OS X) 

Windows Live Writer is a marvelous tool for creating rich content on your blog offline.   It is much more 
powerful than the built-in WordPress visual editor and is particularly useful when publishing text with a 
lot of images or video.  With Live Writer, you create your content offline and publish it using WordPress’ 
built-in XML-RPC protocol (this must be enabled for your blog – see your Settings menu).  

Blogo is the Mac equivalent of Windows Live Writer, and costs about $30.   

The normal way to publish text and images to WordPress is this: 
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1. Capture or save the source image to your hard-drive. 
2. Upload the image in the WordPress visual editor, crop and resize from there. 

This can be a lot of keystrokes and a lot of navigating file directories.  Using Windows Live Writer, you can 
cut both of the above steps short.  What you do is: 

1. Copy the image from any web or disk location (from your web browser, just right-click > Copy); or 
else use a free screen capture utility such as Cropper.  

2. Paste into Live Writer.  You can resize, hyperlink or apply effects (shadow-borders for example) 
to the image directly 

3. Publish your post.  Live Writer will connect to your host and publish the image automatically to 
your wpcontent/uploads directory 

You can also use this technique to generate newsletter emails from WordPress.  First, set up any RSS-to-
email service such as Feedblitz, Feedburner or Aweber. Then just publish a post.  For more information 
see Using Feedblitz or Feedburner as your newsletter system (mailing list management). 

Note: Windows Live Writer only works on Posts (not on Pages).  If you are creating a WordPress static 
Page, just cut-and-paste the generated html from the Post into the Page, then delete the Post. 
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CONCLUSION 

In this guide I have tried to lay out the basic concepts and knowledge you need to design an attractive and 
functional website using WordPress.  Hopefully this has been useful to you (obviously it has, if you have 
read this far  ) 

Of course there is much more that you can learn and do with WordPress – unlike most any other content 
management system ever produced, WordPress is not only free and easy enough for a beginner to use, it 
also allows infinite degree of customization and control.   

If you enjoyed this eBook, I hope that you will consider joining one of our webinars or purchase 
our affordable video training packages, that will teach you a great deal more and  may allow you 
to really

Mazel Tov!  This means, if I understand it correctly, “Good luck has occurred”.  I think the development of 
WordPress is, in fact, a great good luck for all of us self-employed people, small business owners, budding 
entrepreneurs, non-profits and world-changers. 

 create a killer site that will both attract traffic and make you some money.   
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Visit MakeUseOf.com for daily posts on cool websites, free software and internet tips. If you enjoyed this 
guide/manual then subscribe to MakeUseOf.com (via feed or email) and get instant access to several other such 
guides and cheat sheets to your favorite programs. 

- makeuseof.com(latest articles) 
- makeuseof.com/dir/(browse cool websites by category) 
- makeuseof.com/most-popular/(most popular articles) 
- feedproxy.google.com/Makeuseof(feed) 
- feedburner.google.com/fb/a/mailverify?uri=Makeuseof&loc=en_US (subscribe via mail) 

DON’T MISS OUT ON OUR OTHER COOL MANUALS! 

Subscribe via email or RSS to download! 
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